Please wait a minute...
Frontiers of Electrical and Electronic Engineering

ISSN 2095-2732

ISSN 2095-2740(Online)

CN 10-1028/TM

Front Elect Electr Eng Chin    2010, Vol. 5 Issue (4) : 475-481    https://doi.org/10.1007/s11460-010-0112-0
RESEARCH ARTICLE
Performance analysis of proxy mobile IPv6 based on IEEE802.16e
Liyuan XIAO(), Jiawei YANG
Information Science Institute, State Key Laboratory of Integrated Service Networks, Xidian University, Xi’an 710071, China
 Download: PDF(353 KB)   HTML
 Export: BibTeX | EndNote | Reference Manager | ProCite | RefWorks
Abstract

Proxy mobile Internet protocol version 6 (PMIPv6) is a network-based mobility management protocol proposed by Internet Engineering Task Force (IETF), which allows nodes to remain service connectivity while moving around in the IPv6 Internet. PMIPv6 is different from the host-based mobility management protocols (mobile Internet protocol version (MIPv6), hierarchical mobile IPv6 (HMIPv6), fast handover for mobile IPv6 (FMIPv6), and fast handover in hierarchical mobile IPv6 (F-HMIPv6)), whose signaling are transferred among some network entities except mobile node (MN). This paper focuses on the analytical modeling of performance analysis for PMIPv6 and other protocols using IEEE802.16-based wireless metropolitan area networks as the wireless access network. The performances of these protocols are evaluated by some metrics like handover latency, service disruption time, and binding update cost. Numerical results show that PMIPv6 has better performance.

Keywords PMIPv6      mobility management protocols      IEEE802.16e      analytical modeling      performance analysis     
Corresponding Author(s): XIAO Liyuan,Email:simple_xly@126.com   
Issue Date: 05 December 2010
 Cite this article:   
Liyuan XIAO,Jiawei YANG. Performance analysis of proxy mobile IPv6 based on IEEE802.16e[J]. Front Elect Electr Eng Chin, 2010, 5(4): 475-481.
 URL:  
https://academic.hep.com.cn/fee/EN/10.1007/s11460-010-0112-0
https://academic.hep.com.cn/fee/EN/Y2010/V5/I4/475
Fig.1  PMIPv6 handover process
Fig.2  Handover process of different protocols. (a) MIPv6; (b) HMIPv6; (c) FMIPv6; (d) F-HMIPv6; (e) IEEE802.16e MAC layer handover; (f) abbreviations
Fig.3  Network model
parametersvaluesparametersvalues
a1t1/ms5
b2t2/ms2
c2c110
d4c22
e6λS0.1
f6Ps0.9
n5Tnego/ms20
v/(m·s-1)20TDAD/ms500
r/m100Tre-entry/ms50
k5
Tab.1  Parameters to calculate performance metrics
Fig.4  Handover latency versus wireless link latency
Fig.5  Service disruption time versus wireless link latency
Fig.6  Binding update cost versus MN’s velocity
Fig.7  Binding update cost versus SMR
1 Gundavelli S, Leung K, Devarapalli V, Chowdhury K, Patil B. Proxy mobile IPv6. IETF RFC 5213, 2008
2 Johnson D, Perkins C, Arkko J. Mobility support in IPv6. IETF RFC 3775, 2004
3 Soliman H, Castelluccia C, El Malki K, Bellier L. Hierarchical mobile IPv6 mobility management (HMIPv6). IETF RFC 4140, 2004
4 Koodli R. Fast handovers for mobile IPv6. IETF RFC 4068, 2005
5 Jung H Y. Fast handover for hierarchical MIPv6 (F-HMIPv6). IETF draft edition, 2005
6 IEEE standards. IEEE standard for local and metropolitan area networks — Part 21: Media independent handover services. New York: IEEE, 2009
7 Lee J H, Chung T M, Gundavelli S. A comparative signaling cost analysis of hierarchical mobile IPv6 and proxy mobile IPv6. In: Proceedings of the 19th IEEE International Symposium on Personal, Indoor and Mobile Radio Communications . 2008, 1-6
8 Baumann F V, Niemegeers I G. An evaluation of location management procedures. In: Proceedings of the 3rd Annual International Conference on Universal Personal Communications . 1994, 359-364
9 Pack S, Kwon T, Choi Y. A performance comparison of mobility anchor point selection schemes in hierarchical mobile IPv6 networks. Computer Networks , 2007, 51(6): 1630-1642
doi: 10.1016/j.comnet.2006.09.002
10 Pack S, Choi Y. Performance analysis of hierarchical mobile IPv6 in IP-based cellular networks. In: Proceedings of the 14th IEEE International Symposium on Personal, Indoor and Mobile Radio Communications . 2003, 3: 2818-2822
[1] WEI Anquan, SHEN Lianfeng. Performance analysis of the periodic sequence DSSS system against CW interference[J]. Front. Electr. Electron. Eng., 2008, 3(1): 79-85.
Viewed
Full text


Abstract

Cited

  Shared   
  Discussed